Forge for version 1.8

Tony wrote:

I can’t find any mods or a Forge version for 1.8.


Hi Tony

You're right, it can take a while for Forge and mods to be updated to newer releases. You can play Minecraft in a previous version though, by using the profile menu to the left on the startup screen. There are instructions in the article How To Set Up A Version Profile that should help.

The main thing is to match the version of the mod to the version that Forge is built to run in. So for example if you download the Forge version for 1.7.10, make sure that any mods you want to run are compatible with 1.7.10.


  • twitter
  • fb